To use the IndustrySafe Safety Management Software, an internet connection and a standard desktop or laptop are all you need.

The following browsers are compatible with IndustrySafe:

Microsoft Internet Explorer v. 11 or later
Firefox v. 27-33 or later
Safari v. 7 or later
Safari (mobile) v. 5 or later
Google Chrome, v. 30-32, or later

For best results we recommend:

Microsoft Windows XP or later
Microsoft Internet Explorer v. 11 or later
Microsoft Office 2003 or later (recommended for manual data analysis)
Adobe Acrobat Reader
Pop-up blockers disabled for the IndustrySafe site
Browser settings set to allow cookies (IE default settings allow cookies)

 

 

Leave a Reply

Your email address will not be published. Required fields are marked *